Visit the main Crossref website

Crossref

TypeError: 'normalizedRecords'?

Hello!

I was trying to deposit a manuscript but this Error is showing up: TypeError: Cannot read property ‘normalizedRecords’ of undefined.

Is anyone familiar with it? I can’t seem to find what’s wrong :confused:

Captura de Tela 2020-04-14 às 20.40.27

2 Likes

Hi @marina,

I received this type of error in last year but @ifarley corrected it.
Thanks to Crossref support staff for timely help.

2 Likes

Hi @marina. I’m happy to help. What is your username and/or DOI prefix, so I can take a closer look at what might be causing this error?

Thanks in advance,
Isaac

Hey! Thanks for the replies!

@ifarley of course! The username is ‘psico’ :slightly_smiling_face:

1 Like

The problem here @marina is that you have entered the same ORCID iD for two of your contributors. It looks like the 2nd and 3rd author on the DOI have the same ORCID iD entered. Please review and correct the error. Once you do, you will be able to register this DOI.

1 Like

Oh :woman_facepalming:

I can’t believe I didn’t notice that… Anyways, already fixed it!

Thank you so much, @ifarley!

2 Likes

I’m always happy to help, @marina. Glad you were able to get it fixed!

1 Like

Hi, I have the same problem: “normalizedRecords” after submit. The username is rine and DOI 10.36559.

Thank you!

Hello @Crie,

So after checking against your account it looks like the issue is that the title you have on Metadata Manager and the title we have on the system against the ISSN 1517-3860 do not match and that is where the errors are occurring.

In Metadata Manager the title is ‘Revista Inteligencia Empresarial’ and on our system the title is currently ‘KMAP CANVAS UMA PROPOSTA DE PRÁTICA PARA MAPEAR CONHECIMENTO APLICANDO DESIGN THINKING’.

Both titles would need to match for the deposits to be accepted. You would need to change the title in Metadata Manager if the one on our system is correctly registered title or I can change the title on our system if you would like me to.

If you are changing the title in Metadata Manager then you would need to remove the title record from the workspace and this would unfortunately lose the articles that are still in draft against the journal.

Do let me know if you need me to do anything further.

Best regards,

Thank you!! You can change the title on system for me.
The correct is “Revista Inteligencia Empresarial”.

When you change the title in Metadata Manager, should I have to add again the articles?

Best Regards,
Elaine

Thank you!! You can change the title on system for me.
The correct is “Revista Inteligencia Empresarial”.

When you change the title in Metadata Manager, should I have to add again the articles?

Best Regards,
Elaine

Hello Elaine,

I have changed the title on the system to ‘Revista Inteligencia Empresarial’ for you now so hopefully you should be able to deposit via Metadata Manager successfully.

Do let me know if you have any issues with this, you shouldn’t need to remove the or change any of the articles in the workspace.

Thanks,
Paul

Bem vindo @Crie a comunidade

Thanks, Paul!

I just deposited the DOI that was already in the workplace after you fixed the title. However, when looking at deposit history, all my attempts from yesterday appear with the error you got right (“ISSN” 15173860 “has already been assigned, issn is assigned to another title KMAP CANVAS”).

Why doesn’t the deposit I made appear now (July 15)? How can I be sure that the deposits worked?

P.S: Only six articles deposited but appear several times in the Doi history (‘failure’).

Thank you very much for your attention.

Elaine (CRIE)

Hello Elaine,

Sorry it looks like the journal level DOI was different in Metadata Manager as it was in the system as well. I have changed this in the system to 10.36559/CKFB5775 for you now so could you try depositing again and see if that helps as well.

I am not sure why it was not showing in the deposit history as it is showing in the submission logs in the admin console.

You can check to see if a DOI is registered or not, by trying to resolve the DOI here, https://0-doi-org.libus.csd.mu.edu/ or http://0-hdl.handle.net.libus.csd.mu.edu/ entering the DOI into the box and submitting. You can also add the DOI to end of the URL https://0-doi-org.libus.csd.mu.edu/ and try resolving that link directly.

If they show an error page when you try to resolve them then you can investigate why.

You can track your submissions directly in our admin system, here are some further details on that.: https://0-support-crossref-org.libus.csd.mu.edu/hc/en-us/articles/115000998823-Tracking-your-submissions

You can also view past deposits in the admin system as well to check if there were any errors that came through on the submission log and you can also see the xml that was sent to us.
This is explained further here: https://0-support-crossref-org.libus.csd.mu.edu/hc/en-us/articles/215884283-Viewing-Past-Deposits

At the bottom of the submission log it will say how many successful records were updated and how many have failed.

If you have records that have failed, there should be an error message attached. Further information on the error messages can be found here: https://0-support-crossref-org.libus.csd.mu.edu/hc/en-us/articles/215789303-Error-and-warning-messages-

If you need any further assistance from us then please do come back to us with further information on the issue including the submission ID.

I hope this helps.
Many thanks,
Paul

1 Like

Thank you for your support, Paul.

All right!

Best regards,

Elaine